今天在配置eclipse开发python的环境,以前一直都是用notepad++写单页的py,今天心血来潮就想配置一下eclipse开发python的环境,而且方便后面的debug跟踪,一切本来进行得挺顺利的,但是发现每次打开eclipse后一直会出现An internal error occurred during: “Check Preferred PyDev Settings”.这个错误,虽然这个只要点击确定之后就不会影响使用的,但是我还是忍不住好奇查了一下,发现原来是eclipse的版本比较低装比较高的pydev插件就会出现这个错误,然后自己就想升级一下eclipse的版本,但是后面出现一系列的状况,最终还是没升级上,主要是因为我这个是用php for eclipse develop的版本,后来想直接从eclipse上面下载最新的版本,然后再装各种插件,而且最新版的eclipse可以直接import各种插件,但是因为各种原因还是出现各种错误。

最终搞了一早上还是没搞好,没时间继续这样耗下去,就算了,反正点击确定之后还是可以继续使用下去,感觉这个版本用得也还好,没必要非得更新到最新版本。而且自己上面安装的插件也挺多的,后面就直接打包了,直接上传到云空间,以后在别的电脑要用的时候直接下载下来就能用了,也不必再去一个个去配置插件。在eclipse里面安上最新的3.0版本的aptanan插件后编写前端的代码时候感觉爽歪歪啊,eclipse自带的编写相关html和js的时候提示并不是很友好!虽然大部分时候自己编写这些代码的时候还是习惯用notepad++直接编写,可能是比较轻便的原因吧!